ShaftDesigner 1.10.0 Released

This article highlights the benefits of the next @ sna“n38|gner

The Shaft Calculation Software

ShaftDesigner major update with a brand-
new Graphical User's Interface (GUI).
ShaftDesigner 1.10 family main differences
compared to the previous version and new
features are demonstrated. Video related to
this topic is also available.
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1. Introduction

For the last 30 years, Intellectual Maritime Technologies have been supplying engineers around the
world with high-quality software for marine propulsion shafting alignment and vibration calculations.
This time we release the significant update of ShaftDesigner to the 1.10 version. This several years work
has resulted in the User’s Interface update as well as the new unique features added. This is a step
forward to provide a comfortable working environment for the user and increase productivity.
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The new interface is based on the ribbon concept, similarly to the modern office and engineering

software GUIs. The ribbon at the top groups the buttons and controls conveniently for the user. The
new interface contains all the features familiar to experienced users of ShaftDesigner. The beginners will
speed up the learning process because now it becomes much easier to find the necessary features.
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2. Changes

Let’s have a look at the main differences in the User’s Interface. The look and feel of the graphical
user’s interface were redesigned significantly, however the main idea of the software is still the same.
Specifically, ribbon toolbars, gradient background, more relevant modern icons’ style.

Old interface New interface
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2.1. Program Options Window

Some windows are completely reworked. For example, program settings allow more convenient and

structured customization of the user interface and workflow.
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2.2. Project Menu

The Project menu was redesigned. In this menu, you can create a project, open, and save projects in
different ways, close current or all projects, set up properties, materials, media, object’s default

parameters and attachments.
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2.3. Help Toolbar

Most of the Help menu functions are moved to the upper right corner of the window and permanently
available for the user. The user’s guide is updated according to the interface changes and new features.
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2.4. The Main Window

Almost all toolbars and menus were replaced with a modern ribbons tab in the upper part of the
window. The ribbon contains several tabs designed to provide different features. Buttons are
automatically collapsed depending on the window size.
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These ribbons can be hidden, as well as the Project Manager and Object Inspector. It makes
ShaftDesigner convenient to use on portable laptops with small screens. For instance, it is very helpful
onboard in the Engine Room. Also, we optimized the workflow for the multiscreen systems.
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2.5. Common Ribbon Tabs

The Home, Tools and Appearance tabs contain the general software functions that are not application-
specific.

The Home tab contains the basic functions and allows creating calculation applications:
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The Tools tab is responsible for the repository, project data, material and media library, new project
settings, units, and other options of the software.
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The Appearance tab allows the user to manage the desktop and arrange the windows.
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2.6. Modeler Tabs

The Modeler and application windows introduce their own tools. The Modeler’s Design tab provides
all tools for creating and editing the Base model.
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The View tab allows adjusting displayed objects, controlling the view, and changing appearance
settings.
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2.7. Applications’ Tabs

Each module is marked by its own context color to improve the feeling of the software. The active
application can be switched in the drop-down list in the upper right corner, in the Project Manager or
in the window tabs. Every user can find the best way to switch between the applications.
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2.7.1. Alignment Application

The Shaft Alignment application operates with 2 own tabs: Design and Calculations. The Design tab
allows adding specific objects, setting up propeller hydrodynamic loads, calculation options,
acceptance criteria, bearings’ offsets, measurements and adjusting view settings.
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The Calculations tab contains all functions related to the Shaft Alignment. This allows the user to find,
set up and run the specific task easily. However, all the calculations are also accessible from the Design
tab by the special drop-down menu.
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2.7.2. Whirling, Axial Vibration and Fatigue Applications

The Whirling Basic and Advanced, Axial vibration and Fatigue applications operate with the single
Processing tab. It provides buttons to create the additional objects, tune and run the calculation,
change the view.
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2.7.3. Torsional Vibration Application

The Torsional vibration application uses the Model and Scheme tabs. The first one is intended for
shafting model operations.
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The second one is designed for creating and editing the Mass-Elastic system, scheme branches, the
Power Table and changing the view. The Scheme tab also contains the buttons to run the Torsional
Vibration Analysis.
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2.7.4. Vibration Calculation Results Tabs

After the vibration analysis calculation was carried out, the various results are shown as a special
Browser which has its tabs. In contrast to the previous version, all parameters, view and reporting
functionality is moved to these tabs to simplify the reports' generation. This approach gives an
additional screen space for the plots and diagrams.
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3. New Features

Now let’s review the most important new features of ShaftDesigner.

3.1. Quick Access Toolbar

It is possible now to add the most frequently used commands to the Quick access toolbar to activate

them at any time.

Geared, States, Acceptance criteria, Sep
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Repository Project Library New Project Settings Mipsvize:he Eibbon
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— 2= Media || in /7 )
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- *iFDEfauPES - | - Files =
' Edit
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3.2. Project Manager Tools

The Project Manager got the new feature, making it a powerful and rapid control center. Now, the
operating state can be easily disabled or excluded from the specific calculation. There is also an option
to run the computation for the active state only. It is available from the calculation menu or quick
access toolbar. You don’t have to open the Calculation Options window to manage operating states to

run.

Also, you can run the computation, open the options window or switch between the calculation types
just in a couple of mouse clicks without seeking the appropriate buttons in the User’s Interface.
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3.3. Propeller Mass, Inertia and Buoyancy Approximate Methods

The default propeller mass and inertia calculation were updated and extended. Now each parameter
has several approximate methods with a clear formula. It allows estimating the absent initial data in a

more reasonable way. Mass properties are automatically recalculated with the changed propeller
parameters if the approximate formula is chosen.

Mass X Polar Inertia X
Mass, kg |6725.315 Polar Inertia, kg*m*2 |3813.376
At ok o) A | 4
M=p|(14+153D)— + x=0,00028pD0" — | — +3
e ( }AO 4:1000 4 g Ay | Ay
| OK | | Cancel | | OK | | Cancel |

Also, the propeller buoyancy can be determined by a new approximate formula for a partially
submerged propeller, depending on propeller immersion level. It was created by our research and
development department based on a statistical approach, see our article for more information.

Buoyancy X 100
Method Approximate formula - 90 -
B kM 15871 o
uoyancy, s sok
Buoyancy Percent, % |100.000 :—\
ae T0F
= N,[o 5+ sign Im (3 441im] - 9.302]im|* + 11.39|im[* - 6. 103|;m|“}] £ ~ Propeller Jé |
Fa=Fgrual 0. g : ' ' ' = 6hr - Propeller Ne 2
g - Propeller Xe 3
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,? 40 Propeller e 7
= “+« Propeller Ne 8
) - Propeller N 9
0
5 30r Propeller Ne 10
s e e - Propeller Ne 11
& 20+ Propeller Ne 12
Propeller Ne 13
""" - Propeller No 14
10 - — A pproximate
- = Linear law
- . = = = Linear law
0 1 1 1 1 1 1 1 1 ]
0 10 20 30 40 50 60 TO 80 90 100

Propeller Immersion Level Im, %
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3.4. Strain Gauge Measurements

We introduce the absolutely new tool for strain gauge measurements processing. The practical
engineering work is the base for this new tool. All measurements can be stored directly in the project.

@ Strain Gauge Measurements X
Sessions
Session Name Gession 1] || chamnel [ unit | 7 5 B P Vert., MPa Hor., MPa |
_— 57.06.2072 14:05:16 | |Fwd sterntub [ustr 267.010| 255.080| 242,190 253.960 -1.217 0,055
_ SGloc4  |ustr 395,080 396,870 412070 410,290 0.833 0,558
Shaft Turning 240 SGloc3 st 85.340)  48.510 1630 -35.190 4,266 0,653
Measurement Assignment [Strain gauge Alignment | |SG loc 2 pstr -31.330 -20,980 -53.520 -73.840 -1.579 2.593
5Gloc 1 pStr 43.720)  -39.320 5180  -14.590 2.136 -1.213
Aft Motor DE |uStr 285,680 282,920 283260 285920 0.119 0.147
Readings Validity Ched: 0K
Edit Session... |
Session Name Session 2 | chamnel [ wmit | T 5 B P Vert., MPa Hor., MPa
P 22.06.2022 14:05:16 | |Fd sterntub [uStr 466,520 -530.150, -518.830| -455.270 -2.566 -3.673
_ sGloc4  |ustr 37.920)  33.850|  45.530]  49.590 0.373 0.772
Shaft Turning Cw 5G loc 3 pstr 65.670| 44390 -33.720| -61.110 1.273 0.820
Measurement Assignment Reverse Calculation SGloc2 pstr -79.540 -46.6490 -22,290 -54.7490 2.803 0,397
5Gloc 1 pStr 285.420| 289.220| 209.780)  205.640 3,710 4,099
Aft Motor DE |uStr 330,060 -341.430) -335.010| -374.620 2,161 1628
Readings Validity Check: 0K
Edit Session... |
| - Add Session | | ¢ Clear | Show [All + | Readings Validity Eps, % 3.0% | oK | ‘ Cancel ‘

Moreover, measured strains or millivolts can be converted to stresses automatically, taking into
account the bridge’s configuration. We eliminated any kind of hand calculations to prevent errors.
Calculated stresses can be used in reverse calculation and strain gauge alignment. However, it is still

possible to enter stress manually.

Session 1 X
Session
Name [session L Shaft Tuming [CW ~ | Measurement Assignment [strain gauge Algnment - Name [Session 1 shaft Tuming [Cw ~ | Measurement Assignment Strain gauge Alignment -
Date  [22.06.2022 1%:05:16 ~ | comment Date  [22.06.2022 14:05: 16 ~ | Comment
Channel | &l Channels Channel [l Charmels |
~Ciruit Configuration
Fud sterntube at 7520.000 mm, pStr SG loc 4.2t 2682.000 mm, pStr 5Gloc 3 at 14861600 mm, Str
Fd sterntube v €
267.010 395.080 85,340
Strain gauge
Position, mm 7520,000
253,960 255,080 410.290 396,870 -35.190 -48.510
Make Vishay
Tipe CEA-06-250UT-350
242,190 412,070 1630
Resistance R}, 2 0.000)
Readings Valdity Chedk: OK. Readings Vaiidty Chede: OK. Readings Validty Ched: OK
Gage Factor (GF) 2.100)
Vertical Stress (T), MPa -1.217] Vertical Stress (T), MPa 0.833] Vertical Stress (T), MPa 4.266
Bridge Type Full Bidge -
Horizontal Stress (P), MPa 0.055 Horizontal Stress (P), MPa -0.658 Horizontal Stress (P), MPa -0.653|
Sense Connection Yes -
SGloc 2 at 20916.000 mm, St 56 loc 1at 23744800 mm, uStr Aft Motor DEat 29835.200 mm, LStr
s ws = [= 1 Pasition Angle, deg Reading (Vr), uStr 31330 —=8.720 285.680
1 [tp(n 0 2657.010
2 Starboerd Sde (5) % 255,080 m m m
‘ Aty to Al Channdls ] 3 |ottom () 180 242.190 73840 -20.580 -14.590) 39.320 285.920 262,520
| 4 [portSide (P) 270 253.960
Shaft material Readngs Valdity Chede. OK Chanrnel [ unt T [ s | B 3 Vertical Stress (1), MPa_| Horizontal Stress (), MPa |« ]
SGloc 4 st 395.0800 396.8700| 412.0700] 410.2500 0.833 0.658
Elasticty Modulus (5), IPa 206000,000] || Readings Validity Eps, % [3.0 Vertical Stress (T), MPa -1.217) SGloc 3 ustr 65,3900 48,5100 16300| -35.1500 4,266 0.653
R = SGloc 2 st ~31.3300] -20.9800] -63.5200| -73.8400 1579 2593
T orizontal Stress ), WPa X
Poissoris Ratio () 0.300) = 56 loc 1 LSt ~48.7200| -33.3200 -5.1800| -14.5300 2.13 -1.213
AftMotar DE ustr 285.6800 | 282.9200| 283.2600| 285.9200 .19 0.147
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3.5. Reverse Calculations

The reverse calculation is significantly improved. In addition to the updated window with more
convenient and structured buttons, the calculation algorithm became more efficient in searching for
actual bearings’ offsets based on the different kinds of measurements.

2D Reverse Calculations *
A+ | K | R EE K
=X L 12
Profiles  Add Profile | Reset Measurements | Calculate Dptlons Explore  Deviations  Acceptance Criteria
Offset, mm
Adjust Bearing Vertical Plane Haorizontal Plane
Initial Initial
O Stern tube bearing aft 0.0000 0.0000
O Stern tube bearing fwd 0.0000 0.0000
Lineshaft Bearing aft 0.0000 0.0000
Lineshaft Bearing middle 0.0000 0.0000
Lineshaft Bearing fiwd 0.0000 0.0000
Rotor shaft bearing aft 0.0000 0.0000
Rotor shaft bearing fwd 0.0000 0.0000
Strain Gauge Measurements |{Custom Stress Variant: - ﬂ 4
Ohbject Vertical Plane Haorizontal Plane -
Parameter Use Marme Measured Measured
[ |Rotor shaft bea f 77627
Jack 3 aft 22,747 0.000
Load, kM -
Jack 2 mid 20,245 0.000
Jack 1 find 22.679 0.000
Fwd sterntube -0.143 0.000
SGloc 4 -3.316 0.000
Bending Stress, MPa SGloc 3 -0.744 0.000
SGloc 2 -0.425 0,225
5G loc 1 2544 0,084
W[ Af Matnr DE 3433 ER-"-v1
[ oc ][ o= |

Also, a new explore goal tool allows researching or adjusting the solution manually in case of advanced
projects.

@ Explore Goal Function [m] X
@ @ O " A | »
+ + O o N
Initial Offsets  Calculated Offsets | Check All  Uncheck All | Mew Limits  Calculate

|Liﬂe;haft Bearing aft: Vertical - Lineshaft Bearing middle: Vertical - | Bearing e Offset, mm
Value | Min | Max | Count

Vertical 0313 |-0.679 |2.036 |10
Horizontal |-0.007 (-5.000 |5.000 (10
Vertical 1490 |0.699 (2921 |10
Horizontal |0.005 |-5.000 |5.000 (10
Vertical 3762 |-3.000 |5.000 |10
Horizontal |-0.065 (-5.000 |5.000 (10
Vertical 6900 |-5.000 |5.000 |10
Horizontal |0.825  [-5.000 |5.000 (10
Vertical  |7.063 |-3.000 |5.000 |10
Horizontal |2.329  [-5.000 |5.000 (10

Lineshaft Bearing aft

IS

5

Lineshaft Bearing midd

r

Lineshaft Bearing fwd

[

Rotor shaft bearing aft

(=1

Rotor shaft bearing fw

Oooo|/o|o|n|& o

.

log ., (Goal Function)

r
minbinginminb ino ineinminwin & ina

Lineshaft Bearing middle: ¥ertical, mm
o o

A

d o z
Lineshaft Bearing aft: Yertical, mm

] Show Values Loegarithmic Levels

Cance'
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3.6. Selected Diagrams

The analysis of the forced vibration results now is more convenient with a new selected diagrams
window. It shows preview of all diagrams that will be included in the report, allows comparing diagrams
for different elements or nodes, parameters and calculation states. The report can be generated
directly from the window.

© Selected Disgrams o x
B O | by [ s
& 3 D H Ae———p
g O B 5 o) EH -

Soect Al ClewAll | Bepont ASttes | Nvigaion | Fites Disgrams  Agply ot Dingrams S

v [

KRR KRR KRR KR KRR R

NAAAAASNS

3.7. Compare reports

The next great new tool is the reports' comparison. It is easy to open several reports in a single window,
scroll them synchronously (if necessary) and compare in a convenient way. This tool also supports PDF
files attached to the project and even external PDF files. This tool is brilliant if you need to check the
reports made from the different states, projects or even 3rd party documents.

Amange  amage
Vereally  Herizontlly

& B & I B %

Lock
Sercll

cantents

Initial Data - Reverse: Harmanic Response
P Tnital Data - Direct Normal and Misfiring: Harmonic Response 1 Caisbon Ootors
c e

vl
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4. Conclusion
There is a summary of main changes in the new version:

Enhanced ribbon user's interface
Program options window redesign
Project manager calculation control
Approximate propeller methods
Strain gauge measurement tool
Reverse calculation improvements
Selected diagrams window

Compare reports tool

At last, there are some important final notes. The main features of the ShaftDesigner software is the
same as you got used to. The projects created in the previous version are fully compatible with
ShaftDesigner 1.10. The new update is now available for all subscribed customers with active service
contract, the new customers and the users with temporary license. Also, you can try the new version
in a free trial full-functional version from our website www.shaftdesigner.software. We encourage you
to try the new updated ShaftDesigner software now and contact us if you have any questions or
suggestions.

The Shaft Calculation Software

Copyright (c) Intellectual Maritime Technologies 2008 - 2022 @ INTELLECTUAL

MARITIME TECHNOLOGIES
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